Child pages
  • Browser compatibility with Wikis at UAlbany
Skip to end of metadata
Go to start of metadata

The current version of Confluence, the software that runs the Wikis@UAlbany service, generally works fine in any modern web browser.  

For more information on supported web browsers, visit: https://confluence.atlassian.com/conf74/supported-platforms-1003129726.html


Need more help? Submit an ITS Service Desk Request.